存档

2009年10月 的存档

在CentOS下安装PPTP的VPN

2009年10月24日 28 条评论

最近买了个基于xen的VPS玩玩,安装LAMP没啥意思。国内网络环境不好,干脆安装个VPN试试。

对于Linux其实我什么都不会的,在google老师的帮助下,总算给我安装好了,记录下来以便查阅。

VPN常用有两种,一种是openvpn,另一种PPTP。前者开源跨平台功能强大,后者简单方便Windows下无需安装客户端。而且从安装上看,PPTP比openvpn简单一点,所以决定安装这个试试看。

这里罗嗦一下VPS吧,常见也两种,一种是基于openvz,另一种基于xen的。区别不多说了,自己问google吧。这里要说的是openvz的绝大多数不能安装PPTP,而xen的没有限制,两个都可以。

 

以下所有命令我都加了下划线,即加下划线的一定是在类似-bash-3.2#的提示符下输入。

SSH登陆VPS,我的系统是64的CentOS 5.4,绝大多数VPS都提供CentOS系统供选择。可以使用这个命令查询:cat /etc/issue

检查内核是否包含mppe,基本上CentOS都有的,输入这个命令,如果是ok就可以:modprobe ppp-compress-18 && echo ok

安装PPTP需要ppp和iptables这两个软件支持,这里用yum来安装,输入这个命令:yum install -y ppp iptables

然后进入tmp目录,需要把pptp软件下载回来,用这个命令:cd /tmp

去poptop官方网站,如果你和我系统一样,直接下载rpm包:wget http://poptop.sourceforge.net/yum/stable/packages/pptpd-1.3.4-1.rhel5.1.x86_64.rpm

×××如果上面命令无效,安装wget吧:yum install -y wget

接下来安装刚刚下载回来的rpm包,输入命令:rpm -ivh pptpd-1.3.4-1.rhel5.1.x86_64.rpm

×××如果上面命令无效,安装perl吧:yum install -y perl

阅读全文...

分类: 我的原创 标签: , ,